Какие проблемы могут возникнуть после обновления WordPress?

Какие проблемы могут возникнуть после обновления WordPress?

На днях вышла новая версия CMS WordPress — 3.5. Разработчики улучшили многие полезные вещи в этой версии. Почитать о ней можна здесь.

Стоит ли сразу обновляться?

Перед тем как обновиться вы должны знать, что обновление может повлиять на работу вашей темы или отдельных ее элементов, а также на работу плагинов.

Перед обновлением движка выясните не вышли ли обновления для вашей темы или плагинов. Если вышли — обновите все, что можна.

После обновления проверьте работу сайта, галерей, виджетов, шорткодов, слайдеров и всех плагинов. Попробуйте добавить новую запись и при этом используйте доступный функционал. После добавления новой записи просмотрите как выглядит эта запись.

Например, у меня после обновления перестали работать шорткоды кнопок, хотя другие шорткоды работали нормально.

Если после обновления движка вы заметили некорректную работу темы или плагинов, то стоит откатиться к старой версии движка и ждать обновления для вашей темы и плагинов (или самостоятельно искать решение).

Почему возникают конфликты темы и плагинов с движком?

Дело в том, что разработчики движка обновляют скрипты и библиотеки (JavaScript-библиотеки, TinyMCE, jQuery, jQuery UI, SimplePie) до последних версий. Эти версии не всегда поддерживаются темами и плагинами которые используют старые версии скриптов и библиотек.

Как откатиться к старой версии движка, например к 3.4.2?

Через FTP залейте файлы старой версии заменяя новые. После закачивания файлов обновите страницу вашего сайта. Сайт попросит обновить базу данных — согласитесь. Зайдите в админку и проверьте версию движка. После этого проверьте работоспособность сайта.

[ideabox]Столкнулись с похожими проблемами? Не знаете как их решить? Нет времени чтобы копаться и разбираться во всем этом? Обратитесь к специалисту![/ideabox]
Рейтинг 0/5 (0 голосов)
 

Добавить комментарий

avatar