qTranslate не работает в WordPress 3.9

qTranslate не работает в WordPress 3.9

Плагин qTranslate 2.5.39 не работает нормально с новой версией WordPress 3.9. Стабильно плагин работает на WordPress 3.8.1.

Проблемы:

— проблема с визуальным редактором
— проблема с полями для ввода перевода
— проблема с загрузкой файлов

Вы можете откатить вордпресс до версии 3.8.1 или попытаться решить проблему конфликтов.

Разработчики плагина предлагают временное решение. Кстати, это решение работает.

Решение

Вам нужно обновить код в этих файлах плагина:
— qtranslate_hooks.php
— qtranslate_javascript.php
— qtranslate_wphacks.php

Находятся эти файлы по пути: ваш_сайт/wp-content/plugins/qtranslate

Посмотреть и скопировать обновленный код можно здесь. Скопируйте код и перенесите в файлы. Сохраните файлы.

Для вашего удобства я подготовил архив с этими файлами.

Скачайте файлы.
Распакуйте на своем компьютере.
Загрузите на сервер (заменяя файлы на сервере файлами из архива).
После этого проверьте работу плагина.

Рейтинг 0/5 (0 голосов)
 

3
Добавить комментарий

avatar
2 Цепочка комментария
1 Ответы по цепочке
0 Последователи
 
Популярнейший комментарий
Цепочка актуального комментария
2 Авторы комментариев
Николай ПекарскийАндрей Авторы недавних комментариев
Андрей
Гость
Андрей

с вп 4.0 пройдет?